Delays and long api call times on STO2 compute.

Incident Report for Safespring

Resolved

We have now fixed the issue and found the root cause for it. Extended monitoring to cover similar incidents in the future in place.
Posted May 15, 2025 - 10:34 CEST

Monitoring

We noticed API calls towards STO2 compute endpoints taking extraordinarily long time to respond/finish, we think we have identified the cause and have taken actions, monitoring of API call duration is in place.
Posted May 15, 2025 - 08:28 CEST
This incident affected: Safespring Compute.