Sto4: Issues in S3

Incident Report for Safespring

Resolved

Investigations have found no clear link between the reported issues and S3 in STO4. The incident has been closed, and we will continue to monitor the status.
Posted Mar 07, 2025 - 16:52 CET

Investigating

We are currently investigating the issue.
Posted Mar 07, 2025 - 14:24 CET
This incident affected: Safespring Storage.