Degraded block storage performance in STO1

Incident Report for Safespring

Resolved

This incident has been resolved.
Posted May 28, 2025 - 10:56 CEST

Monitoring

Storage cluster should be back up and working now, we will continue monitoring it for a while.
Posted May 28, 2025 - 09:15 CEST

Update

We are continuing to work on block storage cluster, updates will follow
Posted May 28, 2025 - 08:56 CEST

Identified

We've identified the cause as a hardware failure and are working to mitigate the impact
Posted May 28, 2025 - 08:21 CEST

Investigating

We are currently investigating an issue with the block storage cluster in STO1, causing volume operations to fail.
Posted May 28, 2025 - 07:48 CEST
This incident affected: Safespring Compute.