Potential login problems on S3 in STO1 for a subset of accounts

Incident Report for Safespring

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 18:03 CEST

Investigating

We're having authentication issues with our S3 service in STO1. We're currently investigating and will get back with more information as soon as possible
Posted Jun 18, 2026 - 15:53 CEST
This incident affected: Safespring Storage.