We have an issue with our mail service provider that affects our support system, RT.
Incident Report for Safespring
Resolved
This incident has been resolved.
Posted Sep 29, 2023 - 13:28 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 29, 2023 - 10:49 CEST
Investigating
If you have any emergency issues please call our office number, +46855107370. Cases that are not urgent will be handled as soon as the mail service is restored.

Sorry for the inconvenience.
Posted Sep 29, 2023 - 10:43 CEST