S3 in OSL2 unavailable

Incident Report for Safespring

Resolved

Wrong site, the issue was at S3 for STO1. It is resolved now.
Posted Feb 27, 2026 - 12:53 CET

Investigating

We are currently investigating this issue.
Posted Feb 27, 2026 - 12:51 CET
This incident affected: Safespring Storage.