Currently we have some issues with our email provider, affecting our support system.

Incident Report for Safespring

Resolved

Email provider is back online and we are seeing tickets being created again.
Posted Mar 05, 2026 - 13:40 CET

Update

We are continuing to monitor for any further issues.
Posted Mar 05, 2026 - 07:28 CET

Monitoring

Currently we have some issues with our email provider, affecting our support system.

The service is unstable so it may lead to slow response times from us on service requests. In urgent cases please call us at +46 855 10 73 70, reach out on slack or use the portal https://safespring.atlassian.net/servicedesk/customer/portals to file for support.
Posted Mar 05, 2026 - 07:25 CET
This incident affected: Support Email.