Problems creating new instances in STO3
Incident Report for Safespring
Resolved
This incident has been resolved.
Posted May 12, 2023 - 09:23 CEST
Investigating
New instances get stuck while building. We're investigating the issue.
Posted May 11, 2023 - 20:07 CEST
This incident affected: Safespring Compute.