Backup: Performance issues with DCO

Incident Report for Safespring

Update

We are continuing to monitor for any further issues.
Posted Nov 24, 2025 - 17:25 CET

Monitoring

With reduced load on the service, performance is expected to improve. We will continue to monitor the situation closely.
Posted Nov 24, 2025 - 15:20 CET

Investigating

We're currently experiencing performance issues with the backup service in DCO. We're working on resolving this as quickly as possible and apologize for the inconvenience.
Posted Nov 24, 2025 - 13:02 CET
This incident affects: Safespring Backup.