Incoming email bounces, including support email

Incident Report for Safespring

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 14:48 CEST

Identified

Incoming emails to our domain is bouncing or getting rejected currently.
For urgent support matters, please phone +46 85-510 73 70
Posted Jun 26, 2026 - 11:32 CEST
This incident affected: Support Email.