Issues with STO1 compute service

Incident Report for Safespring

Resolved

This incident has been resolved.
Posted May 28, 2025 - 16:01 CEST

Monitoring

We have found the problem and applied a fix. We are now monitoring again.
Posted May 28, 2025 - 13:28 CEST

Investigating

We still see some issues with block storage and have started to investigate again.
Posted May 28, 2025 - 12:57 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 10:57 CEST

Investigating

We are currently investigating a possible issue with Safespring Compute. We will continue to post updates until the issue is resolved.
This is an effect of the block storage hardware issue we had earlier this morning.
Posted May 28, 2025 - 09:52 CEST
This incident affected: Safespring Compute.