DCO Backup service down

Incident Report for Safespring

Resolved

System operational again.
Posted Oct 17, 2025 - 10:49 CEST

Identified

Issue found and corrected, starting up service again but might have reduced performance for a moment while checks are ongoing and old scheduled jobs are being run.
Posted Oct 17, 2025 - 08:59 CEST

Investigating

The backup service is currently unreachable, working on getting it back up again.
Posted Oct 17, 2025 - 08:12 CEST
This incident affected: Safespring Backup.