The support/ticket system is currently unreachable.
Incident Report for Safespring
Resolved
Support system back up again. Emailed tickets should arrive as soon as mail servers retry the delivery.
Posted May 24, 2022 - 10:37 CEST
Identified
We are working on getting it back up again, please have some patience while we fix the issue.
Posted May 24, 2022 - 10:35 CEST